GPGPU и видеокарты AMD

Расскажите, пожалуйста, как обстоит дело с GPGPU у AMD. У меня 2900 XT. Стоит ли скачать SDK, или это бесполезно?

Forums: 

Установка и работа StreamSDK

Установил AMDStreamSDK 1.3 beta, пробую запустить любой exe из примеров, ругается на отсутствие библиотеки amdcalcl64.dll, соответственно не компилируются проекты - либовский файл на библиотеку есть, но самой библиотеки, соответственно, нет. В чем может быть причина? Заранее спасибо

Конфигурация: ASUS EAH4850 x2, Windows Vista Ultimate 64-bit SP1, Micro$oft Visual Studio 2008

Отсутствие файла норма, dll

Отсутствие файла норма, dll компонента переехала в драйвер 3 месяца назад. Ваша видеокарта помоему не поддерживается, я видел жалобы на оффициальном форуме. Поддержка должна появится в 1.4 если не ошибаюсь. Проверьте версию драйвера и посмотрите на оффициальном форуме.

Все пошло

Оказывается, 1.3 beta пашет тока с Каталистом 8.12 и больше ни с каким. При установке проверяет версию драйвера и, если это не 8.12, просто не устанавливает исполняемые файлы. И главное - молчком, говорит просто что не соответствует версия драйвера, что, естественно, вызывает жгучее желание обновить драйвера до наисвежайшей версии. Причем данная фича прописана в Brook+_Installation_Notes, так что RTFM :)))
Насчет отсутствия поддержки данной карточки - попробую откомпилировать проект и посмотреть как работает.

Из SDK Installation Notes (1.4 beta)

Поддерживаются следующие чипсеты:
- ATI Radeon HD 2000+ series, HD 3870, HD 4850, HD 4870
- ATI FireGL V7700
- AMD FireStream 9170, 9270

Удачи!

Pages