Комментировать

Ну у меня SDK/Toolkit -

Ну у меня SDK/Toolkit - 3.0beta. В 2.3 нету OpenCL, насколько я помню (могу путать). Там в одном флаконе все нужное для OpenCL, CUDA и DX11 (DirectCompute)

Но Opencl.dll - идет с драйверами ((и компилятор OpenCL который часть драйвера - тоже), не с toolkit. А приложения CUDA 2.3 с новыми драйверами тоже (естественно) работают.

Кроме того, никто вообще не мешает собирать OpenCL-приложения с помощью AMD-шной opencl.lib - и они будут работать под NVidia драйверами (+- interoperability с OpenGL/DX).